I have installed passenger on my Ubuntu 10.x server and I am running Apache2. I have followed the instruction "I think" pretty well. After setting up my virtual host and trying to restart I am getting a failed to start apache error because Documentroot takes one argument. I have the document root set is the thing so I am wondering if you guys could offer some suggestions as to what I may be doing wrong.

I have all my virtual hosts in separate files by domain name, so the directory structure on the server is something like this

/etc/apache2/sites-available/dev.mydomain.com /etc/apache2/sites-enabled/dev.mydomain.com

both files have the following in them but restarting apache only fails when I put the vhost info in the enabled file.

<VirtualHost *:80>
  ServerName dev.mydomain.com
  DocumentRoot /home/myfolder/dev/vb/public    # <-- be sure to point to 'public'!
  <Directory /home/myfolder/dev/vb/public>
     AllowOverride all              # <-- relax Apache security settings
     Options -MultiViews            # <-- MultiViews must be turned off
  </Directory>
</VirtualHost>

Thanks for any help you can offer.

Comments

BTW here is the error I get when restarting apache grab.by/7LS7

Written by mwallace

Accepted Answer

Comments in httpd.conf must go on their own line.

Written by noodl
This page was build to provide you fast access to the question and the direct accepted answer.
The content is written by members of the stackoverflow.com community.
It is licensed under cc-wiki