Does anyone think or know whether PHP 5.2.18 is coming out? I want to finalize my installation with the last 5.2.x and don't want to go through it again. I won't be switching to 5.3 for a long time. Too many sites and deprecated features to go through.

Comments

You can just turn off deprecated warnings. From what I know, no features have actually been removed between 5.2 and 5.3

Written by Jacob

@Jacob You know wrong: php.net/manual/en/migration53.incompatible.php

Written by Alin Purcaru

and php.net/manual/en/migration53.deprecated.php i will miss eregi()

Written by Mike

Accepted Answer

PHP 5.2 is considered as not maintained anymore.

So, in theory, there should be no new version of PHP 5.2 -- and no new version is planned.


See the announcement of PHP 5.2.16 :

This release marks the end of support for PHP 5.2.
All users of PHP 5.2 are encouraged to upgrade to PHP 5.3.


Still, if a very severe / critical bug is detected, it is possible that some PHP code-developper might decide to release a new version, to fix that bug.
That's what caused the release of PHP 5.2.17, for instance.

But this is not something that's supposed to happen ever again : critical bugs are not something you expect ;-)

Written by Pascal MARTIN
This page was build to provide you fast access to the question and the direct accepted answer.
The content is written by members of the stackoverflow.com community.
It is licensed under cc-wiki